19 нояб. 2013 г.

Заметка. 1с тонкий клиент + Apache. Как это сделать.

1. Лезем в  Конфигуратор -> Администрирование -> Публикация на вэб-сервере.
2. Если система не найдет установленный сервер, то выдаст "Web серверы не обнаружены". Выкачиваем Apache.
3. Повторяем попытку 1
4. Если у нас нет компонентов для работы с веб серверами, то получим такую ошибку: Не установлены модули расширения веб-сервера. Следовательно надо установить компоненты из "Выборочной установки" -> "Компоненты веб-сервера".
5. Повторяем пункт 1. В итоге откроется окно с полями:
Имя: - имя БД, которое будет использоваться в Http, лучше использовать латиницу, скажем, market;
Веб-сервер: - текущий установленный веб-сервер;
Каталог: - путь к директории, в которой лежат параметры подключения к БД, например, c:\1c-client;
Публиковать тонкий клиент и веб-клиент - указывает какие клиенты будут доступны для опубликованной БД.
Публиковать Web-сервисы - указывает какие Web-сервисы будут использоваться, они указаны в таблице ниже.
6. Перезапускаем веб-сервис.
7. Подключаемся так: 127.0.0.1/market. Если все сделано верно, то у нас затребует ввод имени пользователя и пароля.

Что поменялось?
В настройках apache (httpd.conf) добавилась строка:
LoadModule _1cws_module "C:/Program Files/1cv82/8.2.13.219/bin/wsap22.dll"
и добавилось еще это:
# 1c publication
Alias "/market" "c:/1c-client/"
AllowOverride None
Options None
Order allow,deny
Allow from all
SetHandler 1c-application

ManagedApplicationDescriptor "C:/1c-client/default.vrd"

Собственно все.

16 окт. 2013 г.

Сброс CISCO 2950 на заводские настройки.

Способ 1 (если есть доступ в систему).
Сразу обращаю внимание, что делать это по удалёнке - не лучшая затея. Придется админить ногами.
После аутентификации даем команду erase startup-config
CISCO_2950>enable
Password: 
CISCO_2950#erase startup-config
CISCO_2950#reload

Система будет спросит надо ли перезагружаться. Подтверждаем действие.
После ребута, получим систему с чистым конфигом, но vlan'ы останутся, а вот конфиг станет чистым, далее запустится диалог первоначальной настройки, но от него можно отказаться.

Способ 2 (когда иного пути нет, а делать надо).
Случилось так, что не смог авторизоваться на CISCO 2950 по причине забытого пароля. Вариант был только один - его сбросить. Но как?
Вот это было в cu (гипертерминале)

CISCO_2950>enable
Password: 
Password: 
Password: 
% Bad secrets

На передней панели зажимаем кнопку MODE. После чего подаем питание.
В окне cu (гипертерминала) должно появиться:
C2950 Boot Loader (C2950-HBOOT-M) Version 12.1(14)AZ, RELEASE SOFTWARE (fc2)
Compiled Tue 14-Oct-03 17:14 by antonino
WS-C2950T-48-SI starting...
Base ethernet MAC Address: 00:11:93:bc:f8:00
Xmodem file system is available.

The system has been interrupted prior to initializing the
flash filesystem.  The following commands will initialize
the flash filesystem, and finish loading the operating 
system software:

    flash_init
    load_helper
    boot

switch: ?
           ? -- Present list of available commands
        boot -- Load and boot an executable image
         cat -- Concatenate (type) file(s)
        copy -- Copy a file
      delete -- Delete file(s)
         dir -- List files in directories
  flash_init -- Initialize flash filesystem(s)
      format -- Format a filesystem
        fsck -- Check filesystem consistency
        help -- Present list of available commands
 load_helper -- Load and initialize a helper image
      memory -- Present memory heap utilization information
       mkdir -- Create dir(s)
        more -- Concatenate (display) file(s)
      rename -- Rename a file
       reset -- Reset the system
       rmdir -- Delete empty dir(s)
         set -- Set or display environment variables
   set_param -- Set system parameters in flash
        trap -- Cause a software breakpoint to occur
        type -- Concatenate (type) file(s)
       unset -- Unset one or more environment variables
     version -- Display boot loader version

Из предложенного, для начала даем команду
switch: flash_init
В противном случае я ничего более сделать не смогу.

Initializing Flash...
flashfs[0]: 4 files, 1 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 7741440
flashfs[0]: Bytes used: 3137024
flashfs[0]: Bytes available: 4604416
flashfs[0]: flashfs fsck took 6 seconds.
...done initializing flash.
Boot Sector Filesystem (bs:) installed, fsid: 3
Parameter Block Filesystem (pb:) installed, fsid: 4

Далее проверяем:
switch: dir flash:
Directory of flash:/

2    -rwx  3132319   <date>               c2950-i6q4l2-mz.121-22.EA14.bin
3    -rwx  1987      <date>               config.text
4    -rwx  5         <date>               private-config.text
5    -rwx  676       <date>               vlan.dat
6    -rwx  13        <date>               env_vars

4603904 bytes available (3137536 bytes used)

Теперь удалим конфиг, в котором лежит пароль.
switch: del flash:/config.text
Are you sure you want to delete "flash:/config.text" (y/n)?y
File "flash:/config.text" deleted

После этого делаем reset. Система перезагрузится и встретит словами:
         --- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: 

На что следует обратить внимание:
0. Оба способа были выполнены по rs-232.
1. Выполнение flash_init обязательно. В противном случае команда dir будет показывать доступность flash, но работать с этой файловой системой не станет.
2. При обращении к файловой системе необходимо заканчивать имя файловой системы знаком ":". В противном случае система не поймет что от нее хотят (dir flash:).
3. Моя задача была сбросить CISCO 2950 на условии, что я не знаю пароль. Если требуется посмотреть текущую конфигурацию CISCO 2950 до полной загрузки, следует вызвать команду cat flash:/config.text

9 сент. 2013 г.

Python with SNMP

Копипаст с laa88.blog.ru:
Пропарился полтора дня с попыткой свящать snmp и python'а.
Сначала пробовал PySNMP — не получилось. При запуске программы орет на пропущенные скобки, хотя все на месте.
Позже пробовал twistedsnmp — такая же проблема где-то пропущена закрывающаяся скобка и программа не запускается.
Отчаявшись — решил собрать библиотеку дла python'а из Net-snmp. При выполнении
python python.sh build
выдается более 20000 строк об ошибках и сообщение, что 'cc' имеет ошибки.
И тут, покапавшись в портах, нахожу программку с невзрачным названием yapsnmp (как позже оказалось это абривеатура). Установка прошла гладко. Но смутил пример автора для выполнения запроса:
yapsnmp.Session('router45-ny').walk('system')
Проблема была в следующем - т.к. у меня все мои девайсы используют разные версии snmp, то в примере автора не было указано ни версии протокола, ни комьюнити. Открыв доки - тоже не нашел ничего внятного, кроме того, что было в общих чертах указано что они могут быть. Попарился немного и... о чудо!!! Программа заработала. Вот так все будет 100% работать:
import yapsnmp print yapsnmp.Session('10.10.1.1', version=2, community='public').walk('ifOperStatus')
А вот, собственно, вывод:
(('ifOperStatus.1', 'up'), ('ifOperStatus.2', 'up'), ('ifOperStatus.3', 'down'), ('ifOperStatus.4', 'down'), ('ifOperStatus.5', 'down'), ('ifOperStatus.6', 'down'), ('ifOperStatus.7', 'down'), ... ,('ifOperStatus.50', 'down'), ('ifOperStatus.51', 'down'), ('ifOperStatus.52', 'up'))

Думаю, что кому-то пригодится.

5 сент. 2013 г.

Вопросы для проведения экзамена по знанию сетевых технологий.

1 Сколько бит в байте?
>> 1 байт = 8 бит



2 Какая характеристика сети позволяет сравнительно легко добавлять в сеть новые узлы без потерь производительности?
>> 



3 Стандарт, определяющий общие правила построения, функционирования и взаимодействия различных канальных сетей.
>> 

4 Какая основная (базовая) логическая топология чаще всего используется в сетях ….?
>> 

5 В аналоговом сигнале присутствует следующие характеристики сигнала? (Выберите все правильные варианты).
>> Высота (H) - динамический диапазон,
>> Ширина (F) - ширина спектра,
>> Длина (T) - длительность сигнала во времени.

6 Максимальное количество комбинаций сигнала в квадратурной амплитудной модуляции (Quadrature Amplitude Modulation, QAM) равно.
>> 

7 Выберите достоинства аналоговой модуляции.
>> Основными достоинствами амплитудной модуляции являются:
>>      узкая ширина спектра АМ сигнала;
>>      простота получения модулированных сигналов.
>> Достоинством частотной модуляции являются:
>>      высокая помехоустойчивость;
>>      более эффективное использование мощности передатчика;
>>      сравнительная простота получения модулированных сигналов.
>>  Достоинствами фазовой модуляции являются:
>>      высокая помехоустойчивость;
>>      более эффективное использование мощности передатчика.


8 Какие цифровые методы кодирования используют потенциальные коды для формирования передачи данных в линиях связи. (Выберите все правильные варианты).
>> 

9 Какие цифровые методы кодирования используют импульсные коды для формирования передачи данных в линиях связи. (Выберите все правильные варианты).
>> 

10 Какой метод физического кодирования используется в ….?
>> 

11 Определите для всех вариантов физического уровня технологии Ethernet единый оптимальный метод кодирования сигнала в линии передачи данных.
>> 

12 Какое основное преимущество многоуровневого моделирования? (Выберите все правильные варианты).
>> 

13 Сколько уровней имеет сетевая модель OSI?
>> 7 (Семиуровневая модель OSI)

14 Укажите все уровни сетевой модели OSI?
Основные функции ….. уровня сетевой модели OSI в следующем. (Выберите все правильные варианты).
>> Физический уровень
>> Канальный уровень
>> Сетевой уровень
>> Транспортный
>> Сеансовый уровень
>> Уровень представления
>> Прикладной уровень

15 Выбрать правильные определения понятия инкапсуляция ?
>> 

16 Выберите все правильные определения понятия 'протокольные единицы данных' (PDU)?
>> 

17 Выберите все правильные ответы для определения БСТ (Базовая сетевая технология)?
>> 

18 Какие стеки протоколов существуют ? (Выберите все правильные варианты).
>> Стек OSI
>> Стек TCP/IP
>> Стек IPX/SPX
>> Стек NetBIOS/SMB


19 Выберите из каких компонентов состоит линия связи? (Выберите все правильные варианты).
>> 

20 Укажите все компоненты, которые можно назвать устройствами DTE? (Выберите все правильные варианты).
>> 

21 Укажите все компоненты, которые можно назвать устройствами DСE? (Выберите все правильные варианты).
>> 

22 При соединении каких типов устройств необходимо применять crossover кабель. (Выберите все правильные варианты).
>> 

23 Как называется метод доступа, применяемый в сетях Ethernet?
>> 

24 Какое максимальное количество коллизий допустимо для одного кадра?
>> 

25 Jam-последовательность имеет длину равную
>> 32 бита

26 Межкадровый интервал (IPG) для Ethernet равен
>> 

27 Что такое битовый интервал?
>> 

28 Выберите существующие разновидности формата кадров Ethernet.
>> 

29 Выберите правильные ответы для определения MAC адреса устройства.
>> 

30 Максимальный размер поля данных в Ethernet DIX-кадре
>> 

31 Какая длительность IPG в Ethernet
>> 

32 Выберите основные характеристики для описания стандарта Wi-Fi 802.11а
>> 

33 Выберите все известные режимы работы Wi-Fi сетей.
>> 

34 Механизмы защиты сетей Wi-Fi следующие
>> 

35 Укажите модификации стандарта IEEE 802.3
>> 

36 Укажите модификации стандарта Fast Ethernet
>> 

37 Тип кабеля, поддерживаемый Ethernet 100BaseT4
>> Витая пара категории 3

38 Вопросы по длинам кабеля в сегментах, диаметрам сети, количествам узлов и т.п.
>> 

39 Существует два основных алгоритма работы коммутатора/моста. Выберите их
>> 

40 Алгоритм работы прозрачного моста.
>> 

41 Применяется ли на сегодняшний день алгоритм маршрутизации от источника в сетях Ethernet.
>> 

42 Продолжите предложение "Предназначение коммутатора/моста состоит в....."
>> 

43 Средствами логической структуризации сети служат такие устройства:
>> 

44 Что дает применение коммутаторов в локальных сетях (отметьте все правильные)
>> 

45 Средствами физической структуризации сети служат такие устройства
>> 

46 На каких уровнях сетевой модели OSI работает сетевой адаптер (NIC).
>> 

47 Какие дополнительные функции коммутаторов вы знаете?
>> 

48 Преимущества использования иерархической адресации в следующем:
>> 

49 Граничное соотношения пропускной способности магистральных каналов от уровня доступа к уровню распределения равно:
>> 

50 К какому уровню иерархической модели построения сети выдвигаются особые требования по скорости коммутации и отказоустойчивости.
>> 

51 Выберите все преимущества использования иерархической модели построения сети. (Выберите все правильные варианты).
>> 

52 На какие характеристики следует обратить внимание при выборе коммутатора. (Выберите все правильные варианты).
>> 

53 Какие основные рекомендуемые характеристики коммутаторов уровня доступа. (Выберите все правильные варианты).
>> 

54 Какие основные рекомендуемые характеристики коммутаторов уровня ядра. (Выберите все правильные варианты).
>> 

55 Для продвижения кадров коммутаторы могут использовать следующие методы коммутации. (Выберите все правильные варианты).
>> 

56 Существует 2 вида сквозной коммутации выберите их:
>> Коммутация с быстрой отправкой (Fast-forward switching)
>> Коммутация без фрагментации (Fragment-free switching)

57 Выберите правильный ответ на определение понятия Fast-forward switching.
>> Коммутация с быстрой отправкой   Коммутация с быстрой отправкой обеспечивает наименьшую задержку, поскольку отправка пакета начинается сразу после получения адреса пункта назначения. Поскольку при таком виде коммутации отправка начинается еще до полного получения пакета, возможны ситуации, когда пакет передается с ошибками. Хотя такое происходит нечасто, а сетевой адаптер пункта назначения обычно отбрасывает пакеты с ошибками при получении, чрезмерный поток данных может оказаться в некоторых ситуациях неприемлемым. Для уменьшения числа пакетов, отправленных с ошибками, рекомендуется использовать метод коммутации без фрагментации. В режиме быстрой отправки задержка измеряется периодом времени от получения первого бита до его отправки, т.е. по принципу "первым пришел — первым ушел" (first in, first out, FIFO). 

58 Выберите правильный ответ на определение понятия Fragment-free switching.
>> Коммутация без фрагментации  При коммутации без фрагментации отфильтровываются пакеты, попавшие в коллизию, которые составляют большинство ошибок при передаче, и только после этого начинается передача. В правильно работающей сети фрагменты, попавшие в коллизию должны иметь размер менее 64 байт. Пакеты размером более 64 байт являются действительными и обычно принимаются без ошибок. При коммутации без фрагментации пакет должен быть проверен на повреждение в результате коллизии до того, как он будет отправлен. При таком способе задержка также определяется принципом FIFO. Задержка обоих способов коммутации определяется тем, когда коммутатор начинает отправку фрейма. Чем быстрее режим коммутации, тем меньше задержка коммутатора. Для ускорения отправки фрейма приходится сокращать время, отводимое на проверку ошибок. При этом качество проверки снижается, что может привести к большему количеству повторных передач. 

59 Существует два основных метода буферизации в коммутаторах. Выберите их.
>> буферизация по портам 
>> буферизация с общей памятью




---------------
Литература/сайты:
3. rz6hpi
4. citforum

---------------

* Сами понимаете, что работы по данному количеству вопросов много. Ответы будут появляться по мере моей загруженности. Надеюсь, что большая часть ответов будет расписана в течение месяца.

30 авг. 2013 г.

Коммерческие проекты.

Для читателей и тех кого интересует.

Среди собственных разработок, кроме организации беспроводного доступа, появились программа автоматизации выгрузки из реестра запрещенных материалов Роскомнадзора (rsoc, zapret-info.gov.ru). Он же Единый "реестр доменных имен, указателей страниц сайтов в сети «Интернет» и сетевых адресов, позволяющих идентифицировать сайты в сети «Интернет», содержащие информацию, распространение которой в Российской Федерации запрещено"

Скрипт написан на языке python. Работает под ОС Linux, для Windows можно собрать по заказу. Если интересует как получить проект, то информацию можно посмотреть в контактах. (e-mail: laa88rf<собака>gmail.com; скайп: laa88rf).

Параллельно веду раскрутку сайта http://elc74.ru
Услуги электрика в г. Челябинск

21 мая 2013 г.

DHCP (option 82) + SNR-S2950-24G

Вот и дошли руки до dhcp с поддержкой option 82. Что за опция объяснять не стану, как говорится, кто в теме, тот поймет.

И так. Программно-аппаратный комплекс:
Foudry BigIron 8000 + B8GMR4 - как router;
SNR-S2950-24G - как коммутатор доступа;
Сервер с FreeBSD 8.3 + isc-dhcp42-server - как, собственно, сервер;
Любой ноутбук с установленной ОС - как клиентская машина.

Приступим.
Схема у нас такова:
в сети 4 устройства (см выше), 2 vlan'а (1 - vlan управления с серверами, 1001 - vlan для клиентов), dhcp-сервер (ip = 10.10.20.31) подключен в 1 vlan, порт 8/8 Foundry BigIron 8000 соединен с 1/26 портом SNR. Клиент с Windows подключен в 1/1 порт SNR. Адресное пространство для vlan 1001 - 10.90.1.0/24

Теперь о конфигах.
Конфиг Foundry BigIron 8000 для 1 и 1001 vlan + router interface:
vlan 1 by port
 tagged ethe 1/2 to 1/8 ethe 2/4 to 2/8 ethe 3/1 to 3/23 ethe 4/24 ethe 8/1 to 8/8
 untagged ethe 1/1 ethe 2/2 to 2/3 ethe 3/24 ethe 4/2 to 4/19 ethe 5/13 to 5/14 ethe 5/17 ethe 5/19 to 5/20
 router-interface ve 10
!
vlan 1001 by port
 tagged ethe 3/15 ethe 8/8
 router-interface ve 499
!
...
interface ve 10
 ip address 10.10.0.1 255.255.0.0
!
interface ve 499
 ip access-group 110 in
 ip address 10.90.1.1 255.255.255.0
 ip helper-address 1 10.10.20.31
!  

Конфиг SNR-S2950-24G:
!
no service password-encryption
!
hostname Switch
sysLocation laa88rf
sysContact laa88rf
!
username admin privilege 15 password 0 admin
username laa88rf privilege 15 password 0 laa88rf
username laa88rf privilege 15 password 0 laa88rf
!
!
!
service dhcp
!
ip forward-protocol udp bootps
!
ip dhcp snooping enable
ip dhcp snooping vlan 1001
 ip dhcp snooping binding enable
!
 ip dhcp snooping information enable
 ip dhcp snooping information option subscriber-id format hex
!         
!
!
!
!
!
sflow version 0
!
!
vlan 1;1000-1001 
!
Interface Ethernet1/1
 switchport access vlan 1001
 ip dhcp snooping binding user-control
 ip dhcp snooping binding user-control max-user 1
!
...
!
Interface Ethernet1/23
 switchport access vlan 1001
 ip dhcp snooping binding user-control
 ip dhcp snooping binding user-control max-user 1
!
Interface Ethernet1/24
!
Interface Ethernet1/25
 switchport mode trunk
 switchport trunk allowed vlan 1;1001 
 switchport trunk native vlan 1000
 ip dhcp snooping trust vlan 1001
!
Interface Ethernet1/26
 switchport mode trunk
 switchport trunk allowed vlan 1;1001 
 switchport trunk native vlan 1000
 ip dhcp snooping trust vlan 1001
!
interface Vlan1
 ip address 10.10.4.43 255.255.0.0
!
interface Vlan1001
!         
!
no login
!
!
end

Конфиг dhcp-сервера:
# dhcpd.conf
## Sample configuration file for ISC dhcpd
## option definitions common to all supported networks...
option domain-name "example.org";
option domain-name-servers 8.8.8.8;
default-lease-time 600;
max-lease-time 7200;
# Use this to enble / disable dynamic dns updates globally.
#ddns-update-style none;
# If this DHCP server is the official DHCP server for the local# network, the authoritative directive should be uncommented.#authoritative;
# Use this to send dhcp log messages to a different log file (you also# have to hack syslog.conf to complete the redirection).
log-facility local7;
local-address 10.10.20.31;
# No service will be given on this subnet, but declaring it helps the # DHCP server to understand the network topology.shared-network 
mysubnets {    subnet 10.10.0.0 netmask 255.255.0.0 {    }
    if exists agent.remote-id {        log ( info, concat(       "Switch MAC:", binary-to-ascii(16, 8, ":", option agent.remote-id),    "Switch port:", binary-to-ascii(10, 8, ":", option agent.circuit-id) ));    }    class "sw01-p01" {        match if binary-to-ascii(       16, 8, ":", suffix(option agent.remote-id ,6) )="0:3:f:27:a6:8a" and binary-to-ascii(       10, 8, ":", suffix(option agent.circuit-id, 1) ) = "1";    }    class "sw01-p02" {        match if binary-to-ascii(       16, 8, ":", suffix(option agent.remote-id ,6) )="0:3:f:27:a6:8a" and binary-to-ascii(       10, 8, ":", suffix(option agent.circuit-id, 1) ) = "2";    }    subnet 10.90.1.0 netmask 255.255.255.0 { option routers 10.90.1.1; option subnet-mask 255.255.255.0; authoritative;     pool {    range 10.90.1.2;    allow members of "sw01-p01"; } pool {    range 10.90.1.3;    allow members of "sw01-p02"; }    }
}

Конфиг Cisco WS-C2950G-48E:

!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname test
!
enable secret 5 $1$uhLK$u8PXnegpvD0iP1z12viFC/
enable password laa88rf
!
ip subnet-zero
ip dhcp relay information option
ip dhcp relay forward spanning-tree
!
ip dhcp snooping vlan 1001
ip dhcp snooping
ip ssh time-out 120
ip ssh authentication-retries 3
vtp domain CDP-LAN
vtp mode transparent
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
vlan 1000-1001 
!
interface FastEthernet0/1
 switchport access vlan 1001
 ip dhcp snooping limit rate 202
!
interface FastEthernet0/2
 switchport access vlan 1001
 ip dhcp snooping limit rate 202
!
...
!
interface FastEthernet0/46
 switchport access vlan 1001
 ip dhcp snooping limit rate 202
!
interface FastEthernet0/47

 switchport access vlan 1001
 ip dhcp snooping limit rate 202

!
interface FastEthernet0/48

 switchport access vlan 1001
 ip dhcp snooping limit rate 202

!
interface GigabitEthernet0/1
 switchport trunk native vlan 1000
 switchport trunk allowed vlan 1,1001
 switchport mode trunk
 ip dhcp snooping trust
!
interface GigabitEthernet0/2
 switchport trunk native vlan 1000
 switchport trunk allowed vlan 1,1001
 switchport mode trunk
 ip dhcp snooping trust
!
interface Vlan1
 ip address 10.10.10.56 255.255.0.0
 no ip route-cache
!
ip http server
no cdp run
!
line con 0
line vty 0 4
 password laa88rf
 login
line vty 5 15
 password laa88rf
 login
!
!
end



Теперь на что следует обратить внимание:
1. ip helper-address 1 10.10.20.31 - адрес сервера указан на L3(!) интерфейсе, для удобства, а не как это предлагается некоторыми администраторами в секции vlan конфига коммутатора.
2. В конфиге dhcp-сервера, "0:3:f:27:a6:8a" - есть mac-адрес SNR-S2950-24G (коммутатора).
3. В конфиге dhcp-сервера, "1", "2" - номера портов.
4. В конфиге cisco, ip dhcp snooping trust - так сказать, доверенный порт для передачи dhcp запросов/ответов. Если не указать его, то к dhcp-серверу никаких запросов не уйдет.
5. Опять же, cisco. Коммутатор сообщает серверу что клиент подключен (ВНИМАНИЕ) в предыдущий порт. Поясню. Клиента подключаем в 12 порт, а коммутатор сообщает, что клиент подключен в 11 порт. Во всяком случае так в моей версии (c2950-i6k2l2q4-mz.121-22.EA13.bin).

На этом, пока, всё. Если будет что-то новое появляться, а именно:
- настройка на работу с коммутаторами d-link;
- прочие проблемы, которые возникают

будут описаны тут.